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Installing MLWorks

1 MLWorks distribution format

MLWorks™ 2.0 is distributed on a CD-ROM and via FTP from Harlequin’s
World Wide Web site. The distributions are produced with InstallShield®.

2 Contacting Harlequin Support

2.1 Personal edition

Users of MLWorks Personal edition may find the newsgroups comp.lang.ml
and comp.lang.functional useful. The product knowledgebase in the Sup-
port area of our website can also be accessed:

http://www.harlequin.com/devtools/ml

2.2 Professional edition

Registered users of MLWorks Professional edition can contact Harlequin Sup-
port via email at:

mlworks-support@harlequin.com
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Please be certain to include the CD serial number in the subject line of your
email message.

If you are not registered, please visit our registration page on our website:
http://www.harlequin.com/devtools/mlworks

You should have your serial number ready. The serial number is located on a
sticker on the back of the CD envelope.

Please contact Harlequin Support in the following circumstances:

® You need assistance with installing or running MLWorks.

If you need a license name and code for MLWorks, please send mail to
mlworks-keys@harlequin.com rather than the miworks-support
address.

® You encounter a bug in the MLWorks software or documentation and
wish to submit a bug report.

® You have any comments or suggestions for improving the MLWorks
software or documentation.

We prefer communication by electronic mail, particularly when you submit
bug reports.

If you use electronic mail and wish to submit a bug report, please fill in the
bug template distributed with MLWorks and then send it to us. You can find
the template in the top-level installation folder in the file bug-template.txt

When you report a bug, it is very important to include a stack backtrace when
necessary. Backtraces are necessary when the bug you are reporting causes
MLWorks to enter the debugger on an unhandled exception.

It is only possible to see a backtrace in the TTY (that is, non-windowing)
debugger, so if you are running MLWorks in GUI mode you must:

1. Choose Usage > General Preferences > General from the MLWorks
podium’s menubar.

A dialog appears.

2. Turn off the “Always use window debugger” option and click OK or
Apply .
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Once you have done this, MLWorks will enter the TTY debugger when you
next reproduce the error. At the “Debugger>" prompt, enter b. MLWorks will
generate a backtrace suitable for submission in a bug report.

3 Suggested minimum system configurations for MLWorks

To run the Windows 95 version of MLWorks 1.1 we recommend at least 20 MB
RAM. For running on Windows NT, we recommend at least 24 MB RAM.

The distribution folder for Windows 95 and Windows NT is 9 MB; the
installed system takes up around 23 MB. Therefore, during installation you
will need around 32 MB of free disk space.

See Section 10 on page 16 for details of how to tune settings in MLWorks and
Windows to improve performance.

4 Installation

Please note that license registration for Professional edition users now takes
place during installation. See “Licenses” on page 12 for details on how to
enter your license information.

4.1 From the CD-ROM
1. Mount the CD-ROM on your CD-ROM drive.

2. Using Windows Explorer, go to the folder containing the MLWorks dis-
tribution.

3. Double-click on setup.exe

The InstallShield application will now guide you through MLWorks installa-
tion.

MLWorks is now fully installed.

4.2 From the World Wide Web

After downloading your MLWorks distribution from the Harlequin web
site, follow these instructions to install MLWorks.
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4. Double-click on the exe file that you downloaded from the Harlequin
web site. This is a self-extracting executable which runs the InstallShield
setup automatically. Click on Setup to start the installation procedure.

The InstallShield application will now guide you through MLWorks installa-
tion.

MLWorks is now fully installed.

5 Licenses

MLWorks will only run in Personal edition mode unless you enter a valid
license during the installation procedure. Licenses can be obtained from Har-
lequin for the Professional edition by sending electronic mail to one of the fol-
lowing addresses:

mlworks-keys@harlequin.co.uk
mlworks-keys@harlequin.com

Licenses can also be served from a copy of the Harlequin License Server dae-
mon running on your internal network.

If you have difficulty with the license code system please contact MLWorks
Support. See Section 2 on page 5 for support contact information.

5.1 The license code system

When you install MLWorks, it prompts you to input your license hame and
code. The following is example output from MLWorks:

Input your license name: MLPRO-WNT-I7TKQ@%
Input your license code: CIF6@@6@436HW8Z

Note: Please reproduce the license name and code exactly as supplied. Pre-
serve the case of alphabetical characters and do not introduce any extra
whitespace (including leading and trailing space). To reduce the likelihood of
error the license code does not use the digits 0 and 1, and all letter are upper-
case.

Also note the following:
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= If the system rejects your license, possibly because it was mistyped,
clicking Retry gives you another chance to enter it.

= The standard Cut, Copy, and Paste keyboard accelerators (Ctrl+X, Ctrl+C
and Ctrl+V) work in the license dialog box.

= If you wish to install MLWorks as a Personal edition, leave the license
name and code fields blank and click on OK.

MLWorks stores valid license information in your home directory in the regis-
try, under HKEY_LOCAL_MACHINE. MLWorks reads the license name and
code from there in subsequent sessions, so you do not need to type them in
again.

If you delete this stored license information, you will have to reinstall
MLWorks in order to re-enter license information.

6 Registry entries and startup files

This section lists all the environment variables and startup files that MLWorks
uses. They are all described in more detail elsewhere in the documentation,
but are listed here for reference.

6.1 Registry entries

Note the case difference in these registry settings between SOFTWARENd
Software

Items in HKEY_CURRENT_USER\Software\Harlequin\MLWorks\

Source Path The compilation system source path.

Pervasive Path

The folder containing the pervasive library units.

Startup Directory

The folder containing the startup files .miworks and
.mlworks-preferences

Items in HKEY_LOCAL_MACHINE\SOFTWARE\Harlequin\MLWorks\2.0\



Installing MLWorks

10

License Saved registration information.

User Saved registration information.

6.2 Startup files

.mlworks

Startup file.

.mlworks_preferences

Saved preferences from the GUI.

7 Contents of the installed MLWorks system

In addition to the MLWorks compiler and interactive environment, the
MLWorks system contains various scripts, manual pages, libraries and a run-
time system executable.

Before we can discuss the contents of the installation in more detail, there are
two concepts to explain: object files and image files.

MLWorks provides a separate compilation system which allows you to com-
pile ML source files down to object files on disk. Object files have the suffix
.mo. They are suitable for loading into the MLWorks interactive environment
(miworks or miworks-basis ) or runtime (via mipervasive.bat  , which
includes the pervasive library code necessary for running all code compiled
by MLWorks) for execution.

In addition, there are facilities in the Professional edition for turning ML
applications you have developed under the MLWorks programming environ-
ment into free-standing files. This delivery process works in two ways; you
can either compile an application down into an executable file packaged with
the MLWorks runtime, or you can save your current session. In the former
case, you can execute the application by running the executable file; in the lat-
ter, you do so by invoking the MLWorks session as saved.

The MLWorks installation provides libraries in the form of source and object
files, and image files. The various MLWorks scripts work with either object
files or image files or both.
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7.1 Documentation

The MLWorks Version 2.0 Release Notes are important reading for all users. This
document is available in the documentation ~ folder as a PDF file:

documentation\release-notes\pdf\RN-2-0.pdf
You will need Adobe Acrobat Reader to read and print PDF files.
It is also available in HTML form under:
documentation\release-notes\htmN\INDEX.HTM

The MLWorks interactive environment is described in the MLWorks User
Guide. This manual is available in the documentation  folder as a PDF file:

documentation\guide\pdAUG_2-0-W.pdf
It is also available in HTML form under:
documentation\guide\htmNINDEX.HTM

The libraries distributed with MLWorks are described in the MLWorks
Reference Manual. This manual is available in the documentation  folder as a
PDF file:

documentation\reference\pdf \ RM_2-0.pdf
It is also available in HTML form under:
documentation\reference\htmNINDEX.HTM

HTML documentation for the Standard ML Basis library can be found with
the URL:

http://www.harlequin.com/products/ads/ml/basis/

7.2 Shortcuts
All the MLWorks shortcuts are located in the installation’s bin subdirectory.
miworks A shortcut that invokes the MLWorks interactive envi-

ronment with only the General structure of the Stan-
dard ML Basis Library.

11
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mlworks-basis

main.exe

main-windows.exe

mibatch.bat

A shortcut that invokes a version of the MLWorks inter-
active environment containing a built-in copy of the full
Standard ML Basis library.

An executable file that invokes the MLWorks runtime
system on the MS-DOS command line, providing stan-
dard 1/0. The runtime system provides support for
running MLWorks object files (mo) and image files
(.img ).

See the output of main.exe -help for more details.

An executable file that invokes the MLWorks runtime in
the Windows context.

A script that invokes MLWorks on the command line as
a batch compiler. It can be used to compile ML source
files (.sml ) into MLWorks object files (.mo)

mlimage-windows.bat

A script that restarts saved MLWorks interactive envi-
ronment sessions (that is, sessions started with miworks
or miworks-basis ). Interactive environment sessions
can be saved to a.img file from the GUI environment
podium window (File > Save Session As ... ) Or program-
matically with the Shell.saveimage  function.

mlimage-console.bat

mlpervasive.bat

A script for running delivered images that run as con-
sole applications in an MS-DOS window, that is, images
that use standard 1/0.

Because main.exe cannot execute object files without a
copy of the pervasive library to hand, it requires you to
pass a copy of the pervasive library to it whenever you
want to execute object files. For convenience, there is a
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script mipervasive.bat  , which is like main.exe but
which loads the pervasive library image, images\per-
vasive.img , automatically. (The various supplied
image files are covered in Section 7.5 on page 20.)

7.3 Libraries

MLWorks comes with a set of libraries. The libraries are supplied in two ways:
1.
2.

As mixtures of source and object files

As image files

The libraries are:

The Standard ML Basis library. This library is an implementation of the
Standard ML Basis library developed by the SML community. It pro-
vides a basic SML toolkit for general programming tasks such as I70;
extensions to the SML type system; internationalization; and Posix sup-
port. The General structure of the Basis library is pre-loaded into the
interactive system in MLWorks, and is therefore permanently available
at the top level.

Object and source files for the Basis library are in the basis compound,
an installation subdirectory. An image file of the Basis library is in
images\basis.img . To use the Basis Library in your own code, you
should make the project basis.mlp  a subproject of your own project.
This project file is found in the basis subfolder.

The MLWorks pervasive library. This library is MLWorks’ own general-
purpose library containing facilities for 1/0, creation of standalone
applications, multiprocessing, profiling, and so on. There is some over-
lap between the facilities provided by the pervasive library and those
provided by the Basis library.

The pervasive library literally pervades the MLWorks environment, as
the permanently available structure MLWorks. Object and source files for
the pervasive library are also available in the pervasive = compound, an
installation subdirectory. An image file can be found in
images\pervasive.img

13
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= The MLWorks foreign interface library. This library is MLWorks’ own
library for interfacing to code written in languages other than Standard
ML. C is the only foreign language supported at present.

Object and source files for the foreign interface library are in the foreign
compound, an installation subdirectory. The image file is
images\foreign.img

= The MLWorks Windows interface library. This library is MLWorks’ own
library for GUI programming through Win32.

Object files for the Win32 interface library are in the winsys compound;
the image file is images\windows.img

Additionally, the MLWorks interactive environment provides the Shell struc-
ture, a library relating to the interactive environment only. This interactive
environment library cannot be used in user applications, and is therefore not
distributed in separate files like the other libraries.

7.4 Image files

Under the images subfolder of your installation folder, you can find the fol-
lowing image files:

basis.img The Standard ML Basis library.

batch.img The MLWorks batch compiler. This is the image loaded
into main-window.exe by the mibatch.bat  script.

foreign.img The MLWorks foreign interface library.

gui.img The interactive MLWorks image with the GUI interface.

This is the image loaded into main-windows.exe by the
miworks shortcut.

guib.img As gui.img , but with a copy of the Standard ML Basis
library preloaded. This is the image loaded into main-
windows.exe by the miworks-basis ~ shortcut.
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pervasive.img The MLWorks pervasive library. This is the image
loaded into main.exe by the mipervasive.bat short-
cut.

windows.img The MLWorks Windows interface library.

Note: miworks , miworks-basis , mlbatch.bat , and mlpervasive.bat were
designed specifically for using batch.img , gui.img and pervasive.img , and
you should use the scripts rather than invoke them directly with
main-windows.exe  Or main.exe . This is particularly important in the case of
guiimg and guib.img , where the corresponding shortcuts miworks and
miworks-basis  set up a number of environment variables derived from the
installation process, and pass particular parameters to the images. Without
these extra details MLWorks would run into difficulty.

8 Organization of the installed MLWorks system

The installation process creates a number of subdirectories of your installation
directory in order to store the various files that make up the MLWorks system.
It is worth knowing a little about what these subdirectories contain.

basis The Standard ML Basis library.

bin The various scripts (mlworks , mibatch.bat , and so on)
and the runtime (main-windows.exe  and main.exe , for
windowing and console applications respectively).

documentation The online documentation for MLWorks 2.0, which con-
sists of the MLWorks User Guide, MLWorks Reference
Manual, the Release Notes and a copy of these Installation

Notes.
examples Example code.
foreign The MLWorks Foreign Interface library.
images The various image files.
objects Compiled files for basis , and utils

15
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pervasive The MLWorks pervasive library.

scripts Contains information for constructing the correct
scripts for your system during the installation of
MLWorks.

utils Signatures related to the Standard ML Basis library.

winsys The MLWorks Windows interface library.

9 Setting up editor support

MLWorks supports a variety of external editors. The following sections of the
main documentation describe how to set up editor support:

< |n the MLWorks Reference Manual, read the sections on the Shell.Editor

structure and the Shell.Preferences structure.
= In the MLWorks User Guide, read the section on “Editing ML Files” in
Chapter 1.

10 Improving performance

The following notes present suitable system settings for running MLWorks on
Windows.

Ensure a minimum amount of disk space. 64MB is plenty for most applica-
tions.

You can control the memory usage of MLWorks with the -limit  n option to
the MLWorks runtime itself, and also by setting the swap characteristics of
Windows. The settings depend on the sort of work you are doing, for example
student work, running a medium-sized application, or large-scale software
development (all figures in MB):
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Table 1 Recommended Windows memory settings (in Megabytes)

Professional | Professional
Personal .
(medium) (large)

~live data 16 24 32
~max. heap size 32 48 48

(no -limit )
suitable -limit ~ value | 32 48 64
~max. heap size 24 32 40

(with -limit )
suitable RAM 16 24 32
reserved swap 64 64 128
minimum swap 23 32 32

The -limit  in Table 1 refers to the -limit  n option to the MLWorks runtime,
which specifies an advisory arena extent size in MB. The default is 100. If you
have problems with memory usage, try this setting first, using the suggested n
from the table above. To change it, edit the miworks shortcut by choosing Start
> Settings > Taskbar , then in the Taskbar properties dialog, choose Start Menu
Programs and click on the Advanced ... button. This explores the start menu
programs. Find and select the miworks shortcut and choose File > Properties .
Then choose Shortcut . The shortcut is presented in the Target text box, and can
be edited there.

Reserved swap is how much disk space you should have available to your vir-
tual memory system. This is what determines whether MLWorks will die from
lack of memory.

Minimum swap is the smallest size you should allow your swap file to
become. You can set this in the Control Panel under System . The operations
necessary differ between Windows 95 and Windows NT.

17



Installing MLWorks

18

On Windows 95, select the Performance page, then click on the Vvirtual
Memory... button in the Advanced Settings pane. Then select the Let me specify
radio button and fill out the fields appropriately.

On Windows NT, select the Performance page, then click on Change... in the
Virtual Memory pane. Then fill out the fields appropriately.

If you still have trouble, we suggest using the Windows 95 System Monitor or
Windows NT Performance Monitor.

In the Windows 95 System Monitor (Start > Programs > Accessories > System
Tools > System Monitor ), select Edit > Add Item . In the Category list, select Mem-
ory Manager, then from Items choose “Swapfile in use” and “Swapfile size”.
Click OK.

In the Windows NT Performance Monitor (Start > Programs > Administrative
Tools [ Common ] > Performance Monitor ), select Edit > Add to Chart . Choose
“Paging File” from the Object drop-down list and “%Usage” from the Counter
drop-down list. Click Add.

The next thing to do is to monitor the chart while you are performing typical
tasks in MLWorks. There is a danger that readings will disappear from the
chart too quickly for you to interpret them. To avoid this, slow down the dis-
play by selecting Options > Chart and changing the “Update interval” slider
setting (Windows 95) or Update Time interval setting (Windows NT).

Diagnosis again differs between Windows 95 and Windows NT. On Windows
95, if the swapfile size goes up and down a lot, the minimum swapfile size
should be increased. If the swapfile size does not go up and down at all, the
minimum swapfile size could be reduced. A suggested number in either case
is 4/3 of the peak value of “Swapfile in use*.

On Windows NT, if the paging file usage stays very low, your PC is not paging
very much and you need not make changes. If the usage gets very high, you
need to reduce the value of -limit  used by the MLWorks runtime, or reduce
the maximum paging file size, or do fewer tasks at once.

Also of interest for monitoring on Windows NT is the “Memory” object and
its “Page Faults/sec” counter. If this remains high (over 100, say; though the
exact number depends on your PC) for a prolonged period, you are thrashing
and need to reduce your -limit , get more physical memory, or do fewer tasks
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at once. Note that the Performance Monitor graphs are scaled independently
of each other.
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